ruby-on-rails-with-ruby2-0

  1. linux mint 15 install ruby 2.0
    • sudo apt-get -y update
    • sudo apt-get -y install build-essential zlib1g-dev libssl-dev libreadline6-dev libyaml-dev
    • cd /tmp
    • wget http://cache.ruby-lang.org/pub/ruby/2.0/ruby-2.0.0-p0.tar.bz2
    • tar -xvjf ruby-2.0.0-p0.tar.bz2
    • cd ruby-2.0.0-p0/
    • ./configure --prefix=/usr/local
    • make
    • sudo make install

  2.  install sqlite3
    • sudo apt-get install sqlite3 libsqlite3-dev

  3.  install rails
    • sudo apt-get install nodejs
    • sudo gem install rails